Service Status Page

Prepaid USPS shipping labels being rejected at drop-off locations

Incident Report for Mercari Status Page

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 13:45 PDT

Investigating

We are seeing reports of prepaid USPS shipping labels being rejected at drop-off locations with messages indicating “unpaid postage.”
We’ve escalated this with USPS and are actively working with them to identify the root cause.

We’ll share updates as soon as we have more information. In the meantime, please reach out to Mercari customer service if you're experiencing this issue.

Thank you for your patience.
Posted Apr 30, 2026 - 10:40 PDT
This incident affects: Mobile Apps, Web site, and Shipping.