Service Status Page
Shipping and Local Delivery Service Disruption: Michigan
Incident Report for Mercari Status Page
Resolved
This incident has been resolved.
Posted May 16, 2024 - 17:12 PDT
Update
We are continuing to monitor for any further issues.
Posted May 16, 2024 - 17:12 PDT
Monitoring
Delays and disruptions can be expected for inbound and outbound shipments across portions of impacted area due to Michigan tornado
We appreciate your patience when receiving, shipping, or rating your orders.


Please see latest status below:
USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
FedEx: https://www.fedex.com/en-us/service-alerts.html
UPS: https://www.ups.com/us/en/service-alerts.page
Posted May 09, 2024 - 09:46 PDT
This incident affected: Shipping.