Service Status Page
Shipping and Local Delivery Service Disruption in Florida due to Hurricane Nicole
Incident Report for Mercari Status Page
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 15:11 PST
Monitoring
Delays and disruptions can be expected for inbound and outbound shipments across portions of impacted area due to Hurricane Nicole. We appreciate your patience when receiving, shipping, or rating your orders.

Please see latest status below:
USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
FedEx: https://www.fedex.com/en-us/service-alerts.html
UPS: https://www.ups.com/us/en/service-alerts.page
Posted Nov 09, 2022 - 14:51 PST
This incident affected: Shipping.