Service Status Page
FedEx shipping label creation is experiencing issues
Incident Report for Mercari Status Page
Resolved
We identified an issue with FedEx label creation between 7:30 a.m. and 8:20 a.m. July 19, PDT. This issue has been resolved. If you haven't received a FedEx label for your orders yet, please go to the Order Status page and recreate a label.
Posted Jul 19, 2021 - 09:07 PDT
Investigating
We're currently investigating issues with FedEx label creation.
Posted Jul 19, 2021 - 08:10 PDT
This incident affected: Shipping.