Service Status Page

Some users experiencing issues with International Shipping Tracking (ECMS)

Incident Report for Mercari Status Page

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 12:20 PDT

Investigating

Some users are experiencing issues with International Shipping Tracking (ECMS)
We're currently investigating the cause.
Posted Jun 22, 2025 - 12:33 PDT
This incident affected: Shipping.