Service Status Page

Elevated Latency Across Mercari Platform

Incident Report for Mercari Status Page

Resolved

This incident has been resolved.
Posted May 02, 2025 - 10:02 PDT

Investigating

We are currently investigating reports of increased latency affecting various parts of the Mercari platform
Posted May 02, 2025 - 09:36 PDT
This incident affected: Mobile Apps and Web site.