Service Status Page

Shipping and Local Delivery Service Disruption Due to Winter Storm

Incident Report for Mercari Status Page

Resolved

This incident has been resolved.
Posted Mar 16, 2023 - 11:42 PDT

Monitoring

Delays and disruptions can be expected for inbound and outbound shipments across portions of impacted area. We appreciate your patience when receiving, shipping, or rating your orders.

Please see latest status below:
USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
FedEx: https://www.fedex.com/en-us/service-alerts.html
UPS: https://www.ups.com/us/en/service-alerts.page
Posted Feb 24, 2023 - 09:29 PST
This incident affected: Shipping.