Service Status Page
UPS SurePost Tracking Not Updating Due to Incorrect Dropoff at USPS
Incident Report for Mercari Status Page
Update
We are continuing to investigate this issue.
Posted Dec 09, 2024 - 17:03 PST
Investigating
Sometimes your tracking information may appear to have not updated after purchasing an item if your order was shipped via UPS SurePost.

In this situation, the most likely scenario is the order was accidentally dropped off with USPS directly instead of UPS. To confirm this is the case, you can find your USPS tracking number by following the steps below.

Go to https://www.ups.com/track, enter your tracking number provided in the Mercari app and click “Track”
Towards the bottom, click “View all Shipping Details”
On the following page, click on “Shipment Details”
Under “Postal Service Tracking ID” you will see your USPS tracking number
This tracking number can be used to track your order via USPS here: https://tools.usps.com/go/TrackConfirmAction_input
Posted Dec 09, 2024 - 17:03 PST
This incident affects: Shipping.