Service Status Page

Paypal and Venmo checkout is currently unavailable

Incident Report for Mercari Status Page

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 13:37 PDT

Investigating

We are currently investigating this issue.
Posted Jun 02, 2025 - 10:56 PDT
This incident affected: Purchasing.