Service Status Page

Shipping Service Disruption Due to Winter Storms and Severe Weather

Incident Report for Mercari Status Page

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 16:24 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 22, 2025 - 16:23 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 04, 2025 - 09:44 PDT

Monitoring

Delays and disruptions can be expected for inbound and outbound shipments across portions of impacted area due to winter storms. We appreciate your patience when receiving, shipping, or rating your orders.

Please see latest status below:
USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
FedEx: https://www.fedex.com/en-us/service-alerts.html
UPS: https://www.ups.com/us/en/service-alerts.page
Posted Mar 19, 2025 - 09:53 PDT
This incident affected: Shipping.