Service Status Page
Problems generating QR Code for UPS shipping labels
Incident Report for Mercari Status Page
Resolved
This incident has been resolved.
Posted Jan 28, 2025 - 21:19 PST
Investigating
Sellers may see errors when viewing the QR code used to print UPS shipping labels at The UPS Store. As a workaround, you may print the regular shipping label from your own printer.

We'll share an update as soon as the problem is resolved.
Posted Jan 28, 2025 - 20:10 PST
This incident affected: Shipping.