Service Status Page
Shipping and Local Delivery Service Disruption: Hurricane Beryl across Southeast Texas
Incident Report for Mercari Status Page
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 12:22 PDT
Monitoring
Delays and disruptions can be expected for inbound and outbound shipments across portions of impacted area due to Hurricane Beryl. We appreciate your patience when receiving, shipping, or rating your orders.

Please see latest status below:
USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
FedEx: https://www.fedex.com/en-us/service-alerts.html
UPS: https://www.ups.com/us/en/service-alerts.page
Posted Jul 19, 2024 - 19:02 PDT
This incident affected: Shipping.