Service Status Page
FedEx shipping label creation is experiencing issues
Incident Report for Mercari Status Page
Resolved
We identified an issue with FedEx label creation between 11:03 a.m. and 12:33 p.m. July 21, PDT. This issue has been resolved. If you haven't received a FedEx label for your orders yet, please go to the Order Status page and recreate a label.
Posted Jul 21, 2021 - 12:48 PDT
Investigating
We identified an issue with FedEx label creation at 11:03 a.m PDT.
Our team is currently investigating the issue and we will update here when the issue is resolved.
Posted Jul 21, 2021 - 11:25 PDT
This incident affected: Shipping.